Documentation

Installing Prerequisite Products

To use GPU Coder™ for CUDA® C/C++ code generation, you must install the following products:

MathWorks Products

  • MATLAB® (required).

  • MATLAB Coder™ (required).

  • Parallel Computing Toolbox™ (required).

  • Neural Network Toolbox™(required for deep learning).

  • Image Processing Toolbox™(recommended).

  • Simulink® (recommended).

Note

If MATLAB is installed on a path that contains non 7-bit ASCII characters, such as Japanese characters, MATLAB Coder does not work because it cannot locate code generation library functions.

For instructions on installing MathWorks® products, see the MATLAB installation documentation for your platform. If you have installed MATLAB and want to check which other MathWorks products are installed, enter ver in the MATLAB Command Window.

Third-party Products

  • NVIDIA® GPU enabled for CUDA with compute capability 3.2 or higher. Is my GPU supported?

  • CUDA toolkit and driver. If you have not installed a standalone driver, install the driver from the NVIDIA CUDA toolkit. Get the latest CUDA toolkit. GPU Coder has been tested with CUDA toolkit 8.0.

    For system requirements and instructions on installing the toolkit, refer to NVIDIA documentation.

  • C/C++ Compiler

    • On the Linux® platform, the GPU Coder uses the GNU compiler (GCC) included with many Linux distributions. CUDA toolkit has strict requirements on the host compiler and C run-time libraries. For information on these requirements, refer to the NVIDIA documentation.

    • On the Windows® platform, the GPU Coder requires Microsoft® Visual Studio®. For supported versions of Microsoft Visual Studio, refer to NVIDIA documentation.

  • To generate CUDA code for deep learning networks

    • GPU optimized NVIDIA CUDA Deep Neural Network library (cuDNN). Get cuDNN library here. GPU Coder has been tested with cuDNN 5.1.

    • Open Source Computer Vision Library (OpenCV) is required for running examples. Download OpenCV from here. GPU Coder has been tested with OpenCV version 2.4.9.

  • For targeting embedded GPU products such as NVIDIA Tegra® based Jetson TX2, TX1, and TK1:

    • CUDA toolkit 8.0 for ARM® and Linaro GCC 4.9 toolchain for the TX2

    • CUDA toolkit 7.0 for ARM and Linaro GCC 4.9 toolchain for the TX1

    • CUDA toolkit 6.5 for ARM and Linaro GCC 4.8 toolchain for the TK1

    To install Linaro tools, see the instructions on Cross-Compilation on Linux.

    Note

    Embedded GPU targeting is supported only from the Linux platform.

Was this topic helpful?