MATLAB Answers

xcorr can't be used

2 views (last 30 days)
Min Wang
Min Wang on 18 Aug 2021
Commented: Min Wang on 24 Aug 2021
Hi, I met a problem as below, who knows which tool box I need to install? The version of matlab I used is R2015b
Thanks

Answers (1)

Adam Danz
Adam Danz on 18 Aug 2021
Edited: Adam Danz on 23 Aug 2021
xcorr does not require Signal Processing Toobox in Matlab R2019a and later.
For Matlab releases prior to 19a,, you'll need the Signal Processing Toobox as the error message indicates. Alternatively, you could compute the cross correlation with your own function or search for an alternative on the File Exchange.
  1 Comment
Min Wang
Min Wang on 24 Aug 2021
I have find some code about xcorr and save it as .m file. then this issue fixed. Thank you all the same.

Sign in to comment.

Tags

Products


Release

R2015b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by