MATLAB Answers

0

Arduino support package in matlab PROBLEM

Asked by chfakht chfakht on 11 Feb 2015
Latest activity Answered by Cesar Hipolito Pinto on 5 Jan 2017
Hello all , i have installed the Arduino support package in matlab , and i have all blocks that come with it in my simulink the problem is that when i try to establish a serial communication i got smth like this :
>> a = arduino
>> Undefined function or variable 'arduino'.
thanks :) nb : i'm using arduino uno

  1 Comment

Hi to all I was able to solve the problem, doing this way download package Arduino Package and copy i to C:\MATLAB\SupportPackages\R2013a\downloads and go to add on and get support package, after login , disconnect network and choose install from folder, the same where you have put it. Than download https://www.mathworks.com/matlabcentral/fileexchange/32374-legacy-matlab-and-simulink-support-for-arduino, ArduinoIO zipfile, unpack it and copy the PDE subdirectory to the same library subdirectory of arduino package in my case, it is this way. where i download the first package to use add on matlab feature C:\MATLAB\SupportPackages\R2013a\downloads and then a created the subdirectory with the package expanded C:\MATLAB\SupportPackages\R2013a\downloads\arduino-1.0-windows\arduino-1.0 here i have the library subdirectory,where you need to bring the PDE subdir from ArduinoIO.zip file; after that you go to Arduino IDE and file-examples-pde-adioes, compile it and upload to arduino, go to MATLAB and select the home directory to the place where you unpack ArduinoIO.zip file, now you can go to console and type a=arduino('com?')

Sign in to comment.

3 Answers

Answer by Ariel
on 20 Apr 2015

Your arduino package was not install. Go to home tag and press the "get support hardware package". Choose uninstall and see if your arduino package is installed

  0 Comments

Sign in to comment.


Answer by Avinash Kumar on 20 Apr 2015

if it is showing that then the setup is not done Properly and Then try a=arduino();

  2 Comments

Hello, I tried that and the previous solution and it doesn't work ! I don't know why . Although when I upload Progs with Arduino IDE it works well . Help me please , and thanks a lot .
did you end up getting this working?

Sign in to comment.


Answer by Cesar Hipolito Pinto on 5 Jan 2017

Hi to all I was able to solve the problem, doing this way download package Arduino Package and copy i to C:\MATLAB\SupportPackages\R2013a\downloads and go to add on and get support package, after login , disconnect network and choose install from folder, the same where you have put it. Than download https://www.mathworks.com/matlabcentral/fileexchange/32374-legacy-matlab-and-simulink-support-for-arduino, ArduinoIO zipfile, unpack it and copy the PDE subdirectory to the same library subdirectory of arduino package in my case, it is this way. where i download the first package to use add on matlab feature C:\MATLAB\SupportPackages\R2013a\downloads and then a created the subdirectory with the package expanded C:\MATLAB\SupportPackages\R2013a\downloads\arduino-1.0-windows\arduino-1.0 here i have the library subdirectory,where you need to bring the PDE subdir from ArduinoIO.zip file; after that you go to Arduino IDE and file-examples-pde-adioes, compile it and upload to arduino, go to MATLAB and select the home directory to the place where you unpack ArduinoIO.zip file, now you can go to console and type a=arduino('com?')

  0 Comments

Sign in to comment.