Effacer les filtres
Effacer les filtres

bode plot overflow?

9 vues (au cours des 30 derniers jours)
aaa
aaa le 11 Juin 2012
Hi ,
Im trying to plot a bode plot but i get the following error.
>> bode(gamma20,{1000,1e6})
Warning: The data cannot be plotted because it is incompatible with the size of the
plot or is missing.
> In warning at 26
In wavepack.waveform.draw at 55
In wrfc.plot.draw at 18
In wrfc.plot.init_listeners>LocalRefreshPlot at 119
In DynamicSystem.bodeplot at 109
In DynamicSystem.bode at 89
Is there a way to bypass this error? I can get the tf to print and show in the command window. It shows a transfer function of degree 2000, but it will not let me plot the bode plot. In the past, i've plotted something up to degree 700 if i recall correctly. What can I do here? Can matlab reduce the size of the tf? Can I just reduce the size of the frequency sweep?
tia
  4 commentaires
aaa
aaa le 3 Juil 2012
Hi Craig,
Sorry for the delayed reply.
I tried this, and even with logspace(1,6,10), I could not get a plot out. Something else I tried was to use minreal.
I just found it very strange that i can get a "finite" transfer function expression in the console window, but still it refuses to make the bode plot.
Do you think it is possible to increase the tolerance when using minreal? What is typically an accepted value to use besides the default value from Matlab?
Thanks for your help.
Craig
Craig le 19 Juil 2012
The plotting algorithm basically calls bode to obtain its numerical values. The warning being displayed is a result of two possibilities.
  1. Trying to plot a system on an existing plot with hold on and I/O size larger than the current plots I/O size
  2. An error occured when computing the response data
If you call bode with output arguments does it error out?
>> [m,p]= bode(gamma20,{1000,1e6});
Regarding using minreal, adjusting the tolerance is an engineering decision you have to make based on your problem.

Connectez-vous pour commenter.

Réponses (1)

aguadopd
aguadopd le 5 Juin 2013
Happened the same to me today, but MATLAB R2013a.
I solved it by setting DEFAULT paths in the SET PATH menu. It may have been caused by an old toolbox I used. I also clicked UPDATE TOOLBOX PATH CACHE, in the general tab in the options.
Hope it works for anyone having the same problem.
Have a nice day!

Catégories

En savoir plus sur Get Started with Control System Toolbox dans Help Center et File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by