Variable access error in Matlab

2 views (last 30 days)
roni zidane
roni zidane on 7 Jan 2019
Hi there,
I never used to have this error message, when i tried to access varible workspace. Since start of this year, i am having the following error, while i "double click and open" (access) variables from workspace.
Does any one have a solution? I am running scripts in 2016b.
Suzan Doornwaard
Suzan Doornwaard on 9 Feb 2020
Hi Walter,
Thanks for the reply. Your suggestion lead to a discovery and eventually I got rid of the issue.
This is what I did:
1) I ran the command you suggested
which -all workspacefunc
and that gave the exact same error I posted above.
2) I re-open my Matlab and I received all sorts of error regarding that has the same name with Matlab's own functions (assert, scalar) and it points out the add-on I am using in the toolbox directory of mine.
3) Funny enough, I deleted the folder but I realized I didn't remove the path to those in Matlab's path. I thought I would receive an error that would say something like "The toolbox you have in path doesn't exist anymore" for such situations but apparently not.
4) Then i simply removed those particular toolbox related paths from the Path. I restarted my Matlab and I didn't have any errors.
5) I ran the functions that I received error and I double clicked the variables this time. No error. So I realize it's simply clashing functions but for some reason the error is not specific enough to point that out or I am not experienced enough with Matlab yet. At least that's what I experienced.
I hope that helps others with the same problem.

Sign in to comment.

Answers (1)

magie on 29 Nov 2019
Edited: magie on 29 Nov 2019
I have the same problem and it appeared out of the blue.
Whenever I double-click on workspace variables or sometimes even when I place the cursor into the command window or in the editor. Sometimes the error message appears when I open Matlab.
I have version 2019b. I work with it for about 2 months now - no problems until yesterday. I never experienced this error and I have been working with version 2014a for a while now.
I didn't change my codes, I do not have any shadow functions. I tried restoring default path, I even re-installed Matlab after fully de-installing the old version.
Nothing helped so far.
If you have any suggestions, thanks in advance.


Find more on Entering Commands in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by