Problem with Simulink Realtime Target on Arduino UNO with Win 7 X64

31 views (last 30 days)
I keep getting the following error. I can't figure this one out.
The call to realtime_make_rtw_hook, during the after_make hook generated the following error: The build failed with the following message: "G:\MATLAB\Targets\R2012b\arduino-1.0\hardware\tools\avr\utils\bin\make": Interrupt/Exception caught (code = 0xc00000fd, addr = 0x4217b3)
The build process will terminate as a result.
Caused by: The build failed with the following message: "G:\MATLAB\Targets\R2012b\arduino-1.0\hardware\tools\avr\utils\bin\make": Interrupt/Exception caught (code = 0xc00000fd, addr = 0x4217b3)
Diogo Queiros
Diogo Queiros on 10 Feb 2017
Im getting the same error but on windows 7, the path is the default path matlab created when i installed the package at C:/MATLAB etc. the file is called untitled. how do i fix this?

Sign in to comment.

Answers (8)

Jorge on 22 May 2013
Another source of error appears to exist when parenthesis in the Windows PATH variable confuse the encoder. However, I've found a workaround:
  • Find the template of the Arduino makefile that MATLAB uses. Mine was located in C:\MATLAB\Targets\R2012b\arduinouno\registry\defarduinogmake.mkt for the Arduino Uno board.
  • Add the following line to the top of the template, right below the header: SHELL=C:/Windows/System32/cmd.exe
So far, now it compiles flawlessly for me.
John Pritchard
John Pritchard on 13 Feb 2015
Edited: John Pritchard on 13 Feb 2015
This worked for me - Running Win 8 x64, R2014b (Student License) with Arduino Uno R3. My problem was that I had installed the Arduino-Simulink support package and upon "Deploying to Hardware" the progress bar would hit 60% then have the problems everyone is describing here.
I did the following as Jorge suggests (note the file paths are different for me):
  1. Installed Arduino-Simulink Support Package
  2. Closed MATLAB
  3. Opened the following file in Notepad++: C:\MATLAB\SupportPackages\R2014b\arduinouno\toolbox\realtime\targets\arduinouno\registry\defarduinogmake.mkt
  4. Added SHELL=C:/Windows/System32/cmd.exe below header (see image below)
  5. Opened MATLAB
  6. typed rehash toolboxcache in the command window
  7. Opened Simulink and now "Deploy to Hardware" completes and runs just fine

Sign in to comment.

java python
java python on 3 Oct 2013
"to the top of the template, right below the header:" . I don't know where that is ? Could you please clarify little bit ? i am able to open the defarduinogmake.mkt file .

Erdi Tac
Erdi Tac on 14 Aug 2014
I did what Jorge suggested and it works. But you need to do more than what is written in his answer. By the way the solution works for all arduino types. I will rewrite Jorge's answer with a few additions:
1) First of all close MATLAB.
2) For arduino uno find the file C:\MATLAB\Targets\R2012b\arduinouno\registry\defarduinogmake.mkt
For arduino nano find the file C:\MATLAB\Targets\R2012b\arduinonano\registry\defarduinogmake.mkt
For arduino mega2560 find the file C:\MATLAB\Targets\R2012b\arduinomega2560\registry\defarduinogmake.mkt
3) Add the following line to the top of the file, right below the header: SHELL=C:/Windows/System32/cmd.exe
The end of the header is where the lines with "#" ends.
By the way the file is read-only. You can edit the file by copying it to desktop for example. Then delete the one at the original location and copy the edited file back to that location.
4) After you do all these restart MATLAB and execute "rehash toolboxcache".
That's all. You're done.
  1 Comment
naymin tun
naymin tun on 20 Dec 2014
Edited: naymin tun on 20 Dec 2014
I worked as you explained but not ok. When I test, this give the same message. So, I closed all matlab and reinstall/update all arduino support package and then rebuild. At that time, the first time of building and ok and the next time, it is not ok and gives the same error message. But my window is Window 8.1. 64 bit Pls, it has solution?

Sign in to comment.

Himesh on 15 Jan 2015
I'm having the same problem, any updates?

jifeng rgj
jifeng rgj on 13 Feb 2015
I also had this problem, and have solved it. Please look at the picture. I changed the "arduino-1.0.5-r2" to "arduino-1.0.5",and then it worked well.

jifeng rgj
jifeng rgj on 13 Feb 2015

Sadan Arshad
Sadan Arshad on 10 May 2015
Hi i tried everything you guys mentioned i am running R2015a on Win 8.1 and still getting the same error with arduino uno.

Rogelio Martínez
Rogelio Martínez on 18 Apr 2018
I had the same problem with MatlabR215a, but the problem was the name of my file. I named it servo and it caused conflicts, I just changed the name to controlpid and it worked.


Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by