Effacer les filtres
Effacer les filtres

LAUNCHXL-F28069M: Does probing work for I2C?

5 vues (au cours des 30 derniers jours)
Khashayar Olia
Khashayar Olia le 18 Avr 2020
I have I2C communication setup between two LAUNCHXL-F28069M boards and it works fine. When I use NVIDIA Jetson Nano board as master for I2C communication, the communication does not work. In order to find the slave address, I run the "i2cdetect" command in Linux which scans the bus to find the connected modules and their addresses. When I run this command, the Jetson (master) scans the bus by sending address claim message at different addresses. Below is a screenshot of the "i2cdetect" message when Launchpad (slave) is not connected, in this example the address is 0x03:
When I connect the launchpad (slave), this is what I get:
There are two issues here, one is the voltage level jumps from 2v to 3.3v when the Launchpad is connected. But the main issue is although the ACK bit is set (by slave?) and the Read/Write bit is also set (by master?) and the launchpad(?) pulls down the bus but it does not send any data.
Based on the user manual, when the slave goes into slave-tx mode, it holds down the SCL to transmit data. and in order to release the SCL, I need to write data to I2CDXR. I do not have the I2X TX block in my simulink block and I don't know what data I need to send in this case. Should I use interrupt in this situation?

Réponses (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by