Effacer les filtres
Effacer les filtres

Yaxis becomes periodic after using ylim

3 vues (au cours des 30 derniers jours)
Zeynab Mousavikhamene
Zeynab Mousavikhamene le 6 Août 2020
Here is the y axis without using ylim:
and here is the yaxis after using ylim([50 100])
why it looks weird? how can I fix the issue?

Réponse acceptée

Walter Roberson
Walter Roberson le 6 Août 2020
I predict that you have either used yyaxis or xxaxis, or else that you have use the older plotyy(), or else that you called axes() more than once with overlapping Position. In such cases, you would have multiple axes in the same location. However, your ylim() call is only affecting one of the axes, so it is getting out of synchronization for labels with the other.
This kind of problem was more likely to happen with plotyy() or calling axes() multiple times.. yyaxis() and xxaxis() are more careful to put the tick labels on opposite side of the graph.
  2 commentaires
Zeynab Mousavikhamene
Zeynab Mousavikhamene le 6 Août 2020
I was using hold on with scatter and it was overlapping. I added ylim manual and resolved. Thanks for the hint.
Walter Roberson
Walter Roberson le 6 Août 2020
Modifié(e) : Walter Roberson le 6 Août 2020
I do not think you can get that particular error unless you have overlapping axes, which you would not get with "hold on"

Connectez-vous pour commenter.

Plus de réponses (0)

Catégories

En savoir plus sur Two y-axis dans Help Center et File Exchange

Tags

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by