MATLAB Answers

Alex
0

GigE Camera Connection: Unable to set Packet Size

Asked by Alex
on 26 Jul 2011
Latest activity Answered by qiang zhong on 4 Jun 2019
I am trying to connect to a Pleora Technologies Analog to digital GigE device that is supposed give me an GigE connection to my analog camera. I can connect to the camera just fine using Pleora's provided GEVPlayer, however when I try to connect to the camera using imaqtool I always get the error:
Error Using ==> imaqdevice.preview at 181 gige: Unable to set PacketSize.
I have tried changing the packet size and saving the settings using GEVplayer, and then reopening the camera in imaqtool but I always get the same error.
In addition I have tried changing the settings on my ethernet adapter to allow Jumbo frames, but with no luck.
Here is my ver data:
MATLAB Version 7.12.0.635 (R2011a)
MATLAB License Number: *******
Operating System: Microsoft Windows 7 Version 6.1 (Build 7601: Service Pack 1)
Java VM Version: Java 1.6.0_17-b04 with Sun Microsystems Inc. Java HotSpot(TM) 64-Bit Server VM mixed mode
MATLAB Version 7.12 (R2011a)
Image Acquisition Toolbox Version 4.1 (R2011a)
Image Processing Toolbox Version 7.2 (R2011a)
Instrument Control Toolbox Version 2.12 (R2011a)
MATLAB Coder Version 2.0 (R2011a)
MATLAB Compiler Version 4.15 (R2011a)

  0 Comments

Sign in to comment.

4 Answers

Answer by Alex
on 20 Jun 2012

Updating to 2011b solved my problems.

  0 Comments

Sign in to comment.


Answer by Walter Roberson
on 26 Jul 2011

There is a bug in 2010b in using GigE vision devices. That's the version before you are using, but the bug was not necessarily corrected immediately. My understanding is that there is a workaround.

  2 Comments

I tried changing the UAC and running as an administer, but still with no luck. Thank you for the suggestion though. Also, which bug are you referring to?
There are a bunch of GigE problems: please see
http://www.mathworks.com/support/bugreports/search_results?search_executed=1&keyword=gige&release_filter=Exists+in&release=0&selected_products=&commit=Search

Sign in to comment.


Answer by Mark Jones on 1 Aug 2011

Hi Alex,
Would you mind contacting our technical support department so that we can work with you in investigating this?
Mark

  2 Comments

Hi Mark, Have you came out a solution for Alex's pocket size issue? I am currently experiencing the same problem. Hope you can shade a light on it if you have worked it out already
Thanks

Sign in to comment.


Answer by qiang zhong on 4 Jun 2019

You only need one command :imaqreset
Do this step each time you turn on the camera to collect data.

  0 Comments

Sign in to comment.