gpuArray not working in matlab!

13 views (last 30 days)
Dariosh
Dariosh on 18 Nov 2014
Commented: Dariosh on 18 Aug 2015
I have matlab 2014b running on my Ubuntu 14.04 LTS 64bit, Nvidia and CUDA (6.5) drivers are the newest. When I use gpuArray I get the following error: "Error using gpuArray The CUDA runtime failed to initialize correctly. This can occur with some older CUDA drivers."
I tried everything but nothing helped. Please help me with this matlab bug.
  3 Comments
Dariosh
Dariosh on 18 Aug 2015
The commands "parallel.internal.gpu.CUDADriverVersion" and "version -modules" is not possible to run on a system with MCR only. Linux server 64-bit without any x-server og display manager.

Sign in to comment.

Answers (3)

Zachary Taylor
Zachary Taylor on 11 Dec 2014
I had a similar issue after ubuntu updated to the nvidia-331 driver today. However the issue went away after I ran matlab with sudo once. I'm guessing it needed permission to modify a file after the driver update.

Dariosh
Dariosh on 12 Dec 2014
The problem solved by removing and reinstalling the CUDA driver. It is working now. No changes in driver and it is the same driver.
parallel.internal.gpu.CUDADriverVersion: ans = 340.29
Thanks!

TJ
TJ on 21 Jan 2015
make sure you have the paths set properly in your .bashrc file (or similar .cshrc file). export CUDA_HOME=/usr/local/cuda export LD_LIBRARY_PATH=${CUDA_HOME}/lib64 PATH=${CUDA_HOME}/bin:${PATH} export PATH

Products

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by