Matlab is deleting first row of my table and setting it as table property VariableDescription

8 views (last 30 days)
Alica Urbanová
Alica Urbanová on 29 Mar 2022
Edited: Alica Urbanová on 31 Mar 2022
Sorry I'm new to Matlab, maybe I'm asking dumb question but does anyone know why is Matlab setting first row of table as VariableDescription (property of table)? It is only happening when my table has only one row, when there are more row in the table it's not happening. Or does anyone know how to stop it from doing so? When this happens my table is size 0(rows)x2(colums) but it should be size of 1(rows)x2(colums)... I even tried to set 'VariableNamingRule' of table to 'preserve' as matlab were suggesting:
table = readtable('filewithtable.csv', 'VariableNamingRule', 'preserve');
But it didn't worked. Have you any tips what I can do?
  1 Comment
Stephen23
Stephen23 on 30 Mar 2022
@Alica Urbanová: please upload two sample files by clicking the paperclip button:
  • 1st file which has only one row
  • 2nd file which has multiple rows

Sign in to comment.

Accepted Answer

Arif Hoq
Arif Hoq on 29 Mar 2022
It should not work in that way.please try this
A=readtable('filewithtable.csv','ReadVariableName',false);

More Answers (0)

Products


Release

R2022a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by