Running two very similar scripts, getting different resolution figures when exported.

1 view (last 30 days)
Hello all,
I am running into an odd figure problem that I've been debugging all day. I have two scripts (code A and code B) that are doing the exact same thing: they are creating box plots with almost identical data. I have not specified the resolution on the images, and I even copied and pasted the figure code between scripts to ensure that it isn't the figure code, however the output image for both codes is very different in resolution. I manually checked the preferences for both code A and code B, and the preferences for exporting images are the same. I've attached images of the difference in resolution.
I can manually set the resolution of figure B, however, when I do that, it has a weird affect in adobe which I would like to avoid.
has any else seen this? I have been working on this all day and cannot find a solution online or in my lab.

Accepted Answer

Jan
Jan on 13 Sep 2022
It looks like one of the figures uses painters and the other one OpenGL as renderer. OpenGL is enabled automatically, if a more than a certain number of elements is displayed.
Set the renderer of the figure manually to avoid this.
  1 Comment
nines
nines on 13 Sep 2022
for anyone in the future looking for crisp figure, here is the code:
set(gcf, 'DefaultFigureRenderer', 'painters');

Sign in to comment.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by