MATLAB Answers

Problem with GUIDE based app and R2015a

7 views (last 30 days)
We have a GUIDE based application that required some work to get functional again with 2014b. Now with 2015a I'm getting the errors below on startup in the main GUIDE function. If I try to open the .fig file it hangs with most but not all of the [complex] dialog displayed. I've searched but can't find anything relevant.
The error message is
Undefined variable "matlab" or class "matlab.settings.Group".
Error in settings (line 35)
group = matlab.settings.Group(s, 'session');
Error in ligoDV_ligoDV_OpeningFcn (line 79)
setappdata(handles.main, 'settings', settings);
Error in gui_mainfcn (line 220)
feval(gui_State.gui_OpeningFcn, gui_hFigure, [], guidata(gui_hFigure), varargin{:});
Error in ligoDV (line 45)
gui_mainfcn(gui_State, varargin{:});
Error in ligoDV_start (line 164)
ligoDV;
ligoDV is the name of the app.
Any clues on how to figure this out would be greatly appreciated.
  3 Comments
Francesco Piccolo
Francesco Piccolo on 28 Aug 2020
Hi, please find attached the an example of the data and the code that is gvivng me the error.
Thanks

Sign in to comment.

Accepted Answer

Dene Farrell
Dene Farrell on 2 Sep 2015
Change the variable "settings" to another name such as "joes_settings".
  2 Comments
Walter Roberson
Walter Roberson on 4 Sep 2015
I would look at that traceback as implying that a routine named "settings" has been called with no arguments when you expected "settings" to be a variable. That would not make "settings" reserved, but it would call for an investigation of why it was not noticed that it was a variable. Is there a load() shortly before that which is "poofing settings into existence" ?

Sign in to comment.

More Answers (2)

Vinod Sudheesh
Vinod Sudheesh on 8 Jun 2015
Hi Joseph,
How are you launching your MATLAB App?. Are you observing this error even when launching the App from the command line by executing the following command?
ligoDV
  2 Comments
Walter Roberson
Walter Roberson on 8 Jun 2015
I have not see a "matlab.settings.Group" before. Could we see the couple of lines before that?

Sign in to comment.


Image Analyst
Image Analyst on 3 Sep 2015
You forgot to attach the m-file, or even the openingFcn() function. Why do you think you should have a structure or class called matlab? I don't. Most likely you created it somehow, like by running some lines of code in your startup.m file or somewhere and this code expected it to be in the local workspace somehow. If you put the cursor in matlab and type control-D, does it send you anywhere (probably not)?
Go to your old installation that works, and run the Dependency Report on your code and see where this "matlab" comes from. Then bring that file over to your new installation.
  1 Comment
Joseph Areeda
Joseph Areeda on 4 Sep 2015
Thanks for your reply. As stated above, after communicating with Tech Support, it turns out settings is part of Matlab (as of 2015a) and cannot be used as a variable in user space. Renaming it (in all 150+ places) solved the problem.
I have yet to find documentation that explains this or lists new reserved words.

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by