MATLAB Answers

SimBiology and the parallel toolbox

2 views (last 30 days)
Scott
Scott on 16 Jun 2015
Commented: Edric Ellis on 17 Jun 2015
I am trying to wrap a parfor loop around a simbiology simulation and am getting odd results that I don't get when I use a regular for loop.
For example, the following line:
set(modelObj.Species(3),'InitialAmount',2000);
gives me this error:
Error using simulateModel>(parfor body) (line 51)
Attempt to reference field of non-structure array.
Another example is this line:
cs=getconfigset(modelObj,'default');
which gives me this error:
Error using simulateModel>(parfor body) (line 54)
Cannot find an exact (case-sensitive) match for 'getconfigset'
The closest match is: getConfigSet in
/Applications/MATLAB_R2014a.app/toolbox/simulink/simulink/getConfigSet.m
Both of these work in a regular for loop. I'm particularly perplexed about the getconfigset. It is almost as if MATLAB forgets about the SimBiology toolbox altogether when running the parallel toolbox and doesn't recognize SimBio functions or objects.
Any suggestions would be much appreciated.

  1 Comment

Edric Ellis
Edric Ellis on 17 Jun 2015
What is the class of modelObj?

Sign in to comment.

Answers (1)

Ingrid Tigges
Ingrid Tigges on 17 Jun 2015
Have a look at this link SimBiology model objects and parallel computing on how you can use model objects in a "parfor" loop.
There are two things I am not sure about based on your question:
  1. Why do you want to use a SimBiology model object in this way?
  2. Are you aware of this parallel example from the documentation?

  0 Comments

Sign in to comment.

Communities

More Answers in the  SimBiology Community

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by