MATLAB Answers

Problem installing Lego NXT Support Package

2 views (last 30 days)
Michal Jan Warecki
Michal Jan Warecki on 21 Sep 2015
Answered: Dan on 14 Nov 2018
Hi! I'm new and need help, and it's urgent.
While installing the support package, I get the following error:
"Error installing third party software Fantom USB Driver: Error executing command "realtime.setup.internal.rtt_fantom_usb_driver_installer('/Users/mikke/Documents/MATLAB/SupportPackages/R2015a/downloads/legomindstormsnxt_download', '/Users/mikke/Documents/MATLAB/SupportPackages/R2015a', 'Fantom_USB_Driver', 'nxt%20fantom%20drivers.zip')"
Could not download Fantom USB driver archive: nxt%20fantom%20drivers.zip."
I installed the Fantom USB driver manually from the downloaded package, but I still can't install the rest of the package. Does anyone know how to install the package? I use Matlab R2015a at OS X 10.11. I was using Matlab R2014b on the same system before, and there were no errors during the installation process, although I was not able to communicate with the Lego NXT device through USB.
  1 Comment
Nicole Rappo
Nicole Rappo on 6 Dec 2015
I have the same problem. Any time I like to install the support package for Lego Mindstorms NXT with Matlab version 2015a, I got "Error installing third party software Fantom USB Driver". Please help!
Thanks, Nicole

Sign in to comment.

Answers (1)

Dan
Dan on 14 Nov 2018
I have the same problem. It seems that some links are broken and the NXT is not supported in the new version of Matlab/Simulink. It is replaced by the mindstorm. Can anybody from Mathworks help us?

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by