MATLAB Answers

GigE camera (FLIR AX-5) no image

3 views (last 30 days)
Hsin-Feng Hsu
Hsin-Feng Hsu on 2 Jun 2016
Commented: Hsin-Feng Hsu on 21 Jun 2016
Image acquisition does recognize the camera and shows the correct supported one format. I pressed the format, the program enters endless loading status (a rotating ring). I tried core 2 processor, core i5, and an i7-3920xm with K3000M. All result in the same rotating ring. The camera works fine with FLIR researchIR software. What wrong is it and how to resolve it? Thanks for your patient help.

  0 Comments

Sign in to comment.

Answers (1)

Madhura Suresh
Madhura Suresh on 3 Jun 2016
Hi Hsin,
I guess you are using IMAQTOOL. Instead of using that, can you try the command line?
To get the gige devices, run
hwinfo = imaqhwinfo('gige')
Then, create a videoinput object using:
v = videoinput('gige',1)
Preview frames using:
preview(v)
Look at source properties using:
src = v.Source

  1 Comment

Hsin-Feng Hsu
Hsin-Feng Hsu on 21 Jun 2016
Thank you for good advice. Sorry you for replying late since I just recover my license for trying too many computer for this in short time.
The ans for imaqhwinfo is
ans =
InstalledAdaptors: {'gentl'}
MATLABVersion: '9.0 (R2016a)'
ToolboxName: 'Image Acquisition Toolbox'
ToolboxVersion: '5.0 (R2016a)'
The response of the suggested commands is
Error using imaqhwinfo (line 109) Invalid ADAPTOR specified. Type 'imaqhwinfo' for a list of installed ADAPTORs. Image acquisition adaptors may be available as downloadable support packages. Open Support Package Installer to install additional vendors.
Any more suggestions for this? Thanks for your patient help.

Sign in to comment.

Sign in to answer this question.