MATLAB Answers

Why is my "Xcelera-CL PX4 Dual" not listed as adapter on imaqhwinfo?

5 views (last 30 days)
Matthias
Matthias on 20 Jun 2016
Commented: Kyohoon Ahn on 2 Mar 2018
I am trying to create a videoinput object for my DALSA Xcelera-CL PX4 Dual framegrabber. When I execute the IMAQHWINFO command as follows:
imaqhwinfo();
I recieve the following output:
InstalledAdaptors: {}
MATLABVersion: '9.0 (R2016a)'
ToolboxName: 'Image Acquisition Toolbox'
ToolboxVersion: '5.0 (R2016a)'
Running the command like this:
imaqhwinfo('dalsasapera')
yields: "Invalid ADAPTOR specified. Type 'imaqhwinfo' for a list of installed ADAPTORs. Image acquisition adaptors may be available as downloadable support packages. Open Support Package Installer to install additional vendors."
I have installed the support package "Teledyne DALSA Sapera Hardware" using the support package installer. According to the documentation this framegrabber should be supported (although i am not sure if a driver version sapera>7.2 is permissible as the documentation is a little bit contradictory here). The setup is working, i am able to capture images with the driver tool CamExpert. The used hardware and software is:
Operating System: Microsoft Windows 7 Ultimate Version 6.1 (Build 7601: Service Pack 1), x64
MATLAB Version: 9.0.0.341360 (R2016a), x64
Image Acquisition Toolbox Version 5.0 (R2016a)
Image Processing Toolbox Version 9.4 (R2016a)
Xcelera-CL PX4 Dual with X64 Xcelera-CL PX4 Driver, 1.41.00.0652
Sapera LT Version, 8.11.00.1621
What is wrong here?

  0 Comments

Sign in to comment.

Answers (1)

Madhura Suresh
Madhura Suresh on 24 Jun 2016
Hi Matthias,
Can you install version 7.2 of the driver? That should work.

  2 Comments

Michael Eschen
Michael Eschen on 12 Jul 2017
Contact Teledyne Dalsa support and request a copy of Sapera LT 7.2. This is the only way you can get this specific version of the software. Uninstall and newer/older versions of Sapera LT (the current version is 8.3) and then install 7.2. Once I did this MatLab was able to recognize the frame grabber and I was good to go!
Kyohoon Ahn
Kyohoon Ahn on 2 Mar 2018
Hi Michael, I have same problem with you, so i need Sapera LT 7.2 version. Could you send the install file of Sapera LT 7.2 version to me? my e-mail address is kh.ahn@kriss.re.kr Thank you!!

Sign in to comment.

Sign in to answer this question.