MATLAB Answers

problems with matlab windows (both editor and command line windows) when using R2016a on ubuntu 16.04

7 views (last 30 days)
Fabiano Baroni
Fabiano Baroni on 20 Jul 2016
Answered: Shannon on 1 Jun 2018
I'm using matlab R2016a on ubuntu 16.04 (64 bits). I'm having problems with the matlab windows (both editor and command line windows). The problem occurs quite reliably every time I use the debugger.
In that case, when I write on the command line or just scroll it up and down, overlapped characters and images appear which make it basically unusable (please see attached png).
There is also a similar problem happening with the editor window: when I use breakpoints, edit the code in the editor window and scroll it up and down, overlapping symbols appear in the "line number" tab (please see attached png; actually I only have one or two breakpoints, all the other symbols are due to the bug).
I use metacity but I also tried other windows manager for ubuntu (compiz, unity) and the problem persists.
Thank you for any help
Screenshots of the command line window:
Screenshots of the editor window:


Ryan on 5 Oct 2016
Also having the same issue, 2016a and 2016b. It seems indigenous to Ubuntu 16.04 -- Definitely did not have this issue before upgrading from LTS Ubuntu 14.
Walter Roberson
Walter Roberson on 1 Aug 2017
R2016b is the first version qualified for 16.04 LTS. There were some graphics libraries issues that made it a nuisance to get R2016a working on 16.04 LTS.

Sign in to comment.

Answers (2)

Mindaugas on 4 Feb 2017
Edited: Mindaugas on 27 Mar 2017
I also had same problem in Linux (Intel graphics card) with MATLAB R2015b, R2016b, R2017a. Workaround is use other JAVA runtime environement. I recommend install and use JAVA 1.8 from Oracle (not Open JDK):
MATLAB_JAVA=/usr/java/jre1.8.0_101/ /usr/local/MATLAB/R2016b/bin/matlab -desktop


Paolo Mesiano
Paolo Mesiano on 27 Jul 2017
Hi! I have the same problem (Ubuntu 16.04) and I tried to use your solution but without success.
After installing the proper java version, I run the command you wrote but I get this error: "Unable to find java library. Please check if you have a MATLAB_JAVA environment variable"
Could you be more specific on how to solve the problem?

Sign in to comment.

Shannon on 1 Jun 2018
Was there a solution for this for Matlab 2017a on Ubuntu 18.04? I'm having the same issue and these solutions aren't working for me.


Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by