Effacer les filtres
Effacer les filtres

Error in Simulink model with Arduino mega....

1 vue (au cours des 30 derniers jours)
D D le 10 Oct 2016
Error when i try to compile Simulink with Arduino Mega....The error is..1.6.1/libraries/Servo/src/avr -o "untitled.o" "untitled.c" untitled.c: In function 'untitled_step': untitled.c:204:1: error: unable to find a register to spill in class 'POINTER_REGS' } ^ untitled.c:204:1: error: this is the insn: (insn 349 348 351 15 (set (reg:SF 138 [ D.2750 ]) (mem:SF (post_inc:HI (reg:HI 16 r16 [orig:177 ivtmp.19 ] [177])) [4 MEM[base: _184, offset: 0B]+0 S4 A8])) untitled.c:103 99 {*movsf} (expr_list:REG_INC (reg:HI 16 r16 [orig:177 ivtmp.19 ] [177]) (nil))) untitled.c:204: confused by earlier errors, bailing out gmake: * [untitled.o] Error 1
please help cant find any info!!

Réponses (2)

INFOZOU le 16 Oct 2016
Modifié(e) : Walter Roberson le 17 Oct 2016
  2 commentaires
D D le 18 Oct 2016
I still have the same error.
D D le 31 Oct 2016
Does anyone else have this issue?

Connectez-vous pour commenter.

Johannes le 8 Mar 2018
I had the same problem with the Arduino Mega 2560 and the Arduino Uno, when I used the State Space Block with a number of states higher than 2. After changing the solver to ode8 (Dormand-Prince RK8(7)), it worked. Here I found this solution:


Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by