The scope in Simulink does not show any thing!

114 views (last 30 days)
Please, when I started to run the following block diagram and open the scope, nothing appeared in the scope! What is the problem ?!

Accepted Answer

Mohammed Hafez
Mohammed Hafez on 18 Oct 2016
I found the solution of the problem, just I made auto scale in the scope and then the graph appeared.
  1 Comment
Derrick Varnes
Derrick Varnes on 6 Sep 2021
Wow. I was having the same issue for many hours and just happened upon this forum. Thank you, this worked for me as well!

Sign in to comment.

More Answers (4)

Pritesh Shah
Pritesh Shah on 15 Oct 2016
Did you run the model??

CHINTALA SUSILA on 15 Oct 2016
save and run the model

LO on 7 Jul 2018
my time.scope shows signals but they do not refresh constantly during continuous acquisition, does anyone have any idea or advice ?
I am using the code from the matlab help page to run the scope ... it could be helpful to see an example with correct syntax (maybe I am doing something wrong)
thanks in advance

Antony Smith
Antony Smith on 1 Jul 2022
I have tried Auto-scaling axes, but I still see nothing on the scope.
Scope works fine for other models with a compile and 10 sec stop time, but this model is continuously simulating?
Anyone know how to continuously display signals during simulation?

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by