MATLAB Answers

Camera does not show up using imaqtool.

17 views (last 30 days)
ROHIT AILA
ROHIT AILA on 14 Nov 2016
Commented: DSB on 22 Apr 2017
Hi,
I am trying to preview my webcam using imaqtool. Below is the code i used. It works fine with webcam support package but when using imaqtool, it shows up like below image.
vid = videoinput('macvideo', 1, 'YCbCr422_1280x720');
preview(vid);

  0 Comments

Sign in to comment.

Answers (2)

Madhura Suresh
Madhura Suresh on 15 Nov 2016
Edited: Madhura Suresh on 15 Nov 2016
Was the webcam object still in the workspace when you previewed this? That webcam object should be deleted, because the camera can be only be accessed by one object at a given point in time. Use
clear cam % where cam is the webcam object

  1 Comment

ROHIT AILA
ROHIT AILA on 15 Nov 2016
Hi Madhura Suresh,
My webcam object was not present int the workspace. Still i tried clearing the cam object. It did not work for me.

Sign in to comment.


Maoqi Li
Maoqi Li on 4 Dec 2016
I have the same problem. So how to solve it?

  4 Comments

Show 1 older comment
DSB
DSB on 22 Apr 2017
did you find any solution ?? I have the same problem you had
Image Analyst
Image Analyst on 22 Apr 2017
If using Windows, then does the camera show up in Device Manager? If not, then not even Windows sees the camera, so MATLAB has no chance at it. If it does, then you may need to register a third party adapter from imaqtool's pulldown menu. Ask the camera manufacturer what that file might be, if they have one. If they don't have one, then maybe you can use a generic one instead like DCAM.
DSB
DSB on 22 Apr 2017
i'm using mackbook pro

Sign in to comment.

Sign in to answer this question.