Effacer les filtres
Effacer les filtres

How can I resolve the firmware update failure for Parrot Minidrone?

26 vues (au cours des 30 derniers jours)
Nicholas Notich
Nicholas Notich le 5 Oct 2017
Commenté : Yanc Pan le 30 Oct 2019
I'm attempting to re-flash a parrot rolling spider drone using the Simulink support package for Parrot minidrones. The reflash fails after rebooting the drone. I'm using Matlab 2017b and the support package from the parrot minidrones hardware support webpage.
  1 commentaire
Yanc Pan
Yanc Pan le 30 Oct 2019
I have meet the same problem,have you slove the problem?

Connectez-vous pour commenter.

Réponses (8)

Ankur Bose
Ankur Bose le 12 Oct 2017
Hi Nicholas, What error are you observing while doing the setup? Can you post a snapshot or the error details? Some of the common reasons that firmware update might fail.
  • The drone is not being detected back after reboot.
  • Firmware update is failing
  • Disconnect the drone , restart it and start the setup process again.
  • Try a different USB port and a different cable.
If these do not resolve your issues, let us know what error you are getting and we will help you out.
  10 commentaires
Ankur Bose
Ankur Bose le 29 Jan 2018
Please see the answer by Ankur Bose on 29 January 2018 for resolution to the firmware update issue.
Julio Cesar Martinez
Julio Cesar Martinez le 15 Juin 2019
Hey Jay, regarding the refurbished Parrot Rolling Spiders I get the same error, but apparently it was only firewall restriction,just disable your firewall and works!

Connectez-vous pour commenter.

Nikhil Tawakley
Nikhil Tawakley le 19 Déc 2017
Can anyone help with this? Matlab is not able to update the firmware as noted in V's post...
  1 commentaire
Ankur Bose
Ankur Bose le 29 Jan 2018
Modifié(e) : Ankur Bose le 29 Jan 2018
Please see the answer by Ankur Bose on 29 January 2018 below for resolution to the firmware update issue.

Connectez-vous pour commenter.

Suze Zhang
Suze Zhang le 9 Oct 2017
Hi Nicholas,
The following link gives several ways to update the software on Parrot Rolling Spider drone. There are steps on solving the update failure in this link as well:
  1 commentaire
Ankur Bose
Ankur Bose le 12 Oct 2017
I believe Nicholas is talking about flashing the drone during setup process of the support package. Please refer to my answer below.

Connectez-vous pour commenter.

Jeremie Pilon
Jeremie Pilon le 15 Jan 2018
Modifié(e) : Jeremie Pilon le 15 Jan 2018
I am having the exact same problem. When I try to write the firmware via the hardware setup, it eventually fails. I have tried different cables and ports, but it still does not work. I have not been able to pass this point with two different rolling spider minidrones.
Please help!
Here are some additionnal tests I performed: I tried to use the hardware setup wizard after have updated the parrot rolling spider using the wifi method and the computer method suggested by parrot. I have tried the same thing after reinitializing the parrot (holding the power button for more than 10 seconds). Nothing works.
Matlab is never able to correctly install its firware onto the parrot.
Jérémie Pilon
  2 commentaires
Srijith Vijay
Srijith Vijay le 24 Jan 2018
Hi Jeremie,
Could you log into the drone via telnet and check if there exists a version.txt file in the root directory?
  1. Connect the drone over USB to the computer and wait till the drone LEDs stabilize to red and green
  2. Open the command prompt and execute "telnet"
  3. Once you have logged into the drone, execute command "ls" to list all the files and directories
  4. Check if "version.txt" file exists
Ankur Bose
Ankur Bose le 29 Jan 2018
Modifié(e) : Ankur Bose le 29 Jan 2018
Please see the answer by Ankur Bose on 29 January 2018 below for resolution to the firmware update issue.

Connectez-vous pour commenter.

Ankur Bose
Ankur Bose le 29 Jan 2018
Hi All,
We have contacted Parrot regarding this issue and they have provided us a workaround to resolve this issue. The fix has already been published in R2017b in the support package version 17.2.3. Please upgrade your support package version to 17.2.3 in R2017b and perform the hardware setup for Parrot Rolling Spider once more.
If you do not wish to upgrade your support package, you can follow the below steps to resolve this issue.
  1. Connect the Parrot Rolling Spider drone to PC. Wait for the LEDs to stabilize to RED and GREEN.
  2. If you are working in Windows PC, install RNDIS as mentioned in this link. Please note that drone has a timeout period of approx 60 seconds after which it automatically disconnects from PC. Hence please complete the RNDIS installation as fast as possible.
  3. Open Windows command prompt. Execute the below command in the command prompt as shown in the snapshot.
If you get an error 'telnet' is not recognized as an internal or external command, operable program or batch file, you need to enable telnet in your Windows PC. Follow the instructions in this MATLAB answer to enable telnet in your PC.
If the command prompt displays the message Connecting to for a long time and then it fails, it might be that the drone has timed out or the RNDIS installation has not gone through.
Reconnect the drone and repeat Step 3. If you still get same error, you need to install RNDIS on the host computer again as mentioned in Step 2. Complete the RNDIS installation as fast as possible.
On successful execution of the command you should see a command prompt window as shown in the snapshot.
  1. On the Delos prompt in the command window, execute the below command
echo "1.99.2" > /version.txt
This would create the missing version.txt in the root folder of the drone, that is required for the firmware update to be successful.
If you get any write permission error while executing this command, try rebooting the drone and repeat the above steps.
After successful execution of the above command, complete the hardware setup screens in MATLAB. They should go through without any issue.

Jay Chuck
Jay Chuck le 29 Jan 2018
Modifié(e) : Jay Chuck le 29 Jan 2018
Even with the new 17.2.3, it is still not going past the update firmware stage. It is going farther than previously but it still fails with this new error. Any guidance MATLAB guys?
  2 commentaires
Ankur Bose
Ankur Bose le 29 Jan 2018
Modifié(e) : Ankur Bose le 29 Jan 2018
Hi Jay,
The firmware for your Parrot Rolling Spider is successfully updated. However, in your case, the support package upgrade to version to 17.2.3 has not gone through properly. That is the reason you are getting this error.
You can try the below steps:
  1. Restart MATLAB and restart your drone.
  2. Perform hardware setup screens again .
  3. If you get any similar error like above that says "unable to find message key", exit the hardware setup screens. Uninstall the currently installed support package. Clear the support package download folder.For Windows, the download folder is typically located at for ex- C:\Users\abose\Downloads\MathWorks\SupportPackages\
Clear the parrot support package installation folder (if it exists). The installation folder is typically located at for ex- C:\ProgramData\MATLAB\SupportPackages\R2017b\toolbox\target\supportpackages\parrot .
Delete the parrot folder in below location (if it exists). C:\ProgramData\MATLAB\SupportPackages\R2017b\resources\parrot
Open MATLAB and install the support package for Parrot Minidrone again. Restart your MATLAB once after installation and perform the hardware setup.
Jay Chuck
Jay Chuck le 13 Fév 2018
1. I can confirm that my firmware update now finished successfully. 2. I did a clean reinstall of MATLAB and the support package.
Thanks for your help on this.

Connectez-vous pour commenter.

Massimo Satler
Massimo Satler le 7 Mar 2018
I am experiencing Bluetooth connection problem with my rolling spider. The Firmware update process was successfully done, then I tried to connect the rolling spider by BLE but it fails with the following error message "Unable to create a Bluetooth network interface. Ensure that relevant drivers are installed for the Bluetooth adapter and click Next to proceed." (More over the terminal shell used to launch matlab reports >> sh: 1: pand: not found )
Looking for a solution I found the instruction for the manual procedure but it recommends to use the "pand" command which is deprecated (if I am not wrong) on Ubuntu. How can I solve the problem?

Massimo Satler
Massimo Satler le 7 Mar 2018
I solve with: bt-network -c < minidrone MAC address > gn
  1 commentaire
Ankur Bose
Ankur Bose le 8 Mar 2018
I guess you are using Ubuntu 16.04 version or later. In these version's we do not yet have support for rolling spider. The 'pand' APIs have been deprecated after 14.04 LTS. The bt-network API is shaky and might not work for some cases.
If you have managed to get your drone connected using bt-network , then you also need to set the IP of the created interface so that you can deploy code from Simulink.
Hence after successful connection of the drone, do 'ifconfig'. You should see a network interface 'bnep0'. Set the IP of the this interface to
sudo ifconfig bnep0 up
ping the drone to make sure the connection is successful.
ping -S

Connectez-vous pour commenter.


En savoir plus sur MATLAB Support Package for Parrot Drones dans Help Center et File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by