MATLAB Answers

Ettus E310 setup issues. Incompatible Hardware.

4 views (last 30 days)
Will Thompson
Will Thompson on 28 Nov 2017
Answered: Neil MacEwen on 23 Feb 2018
Hi All.
I'm trying to get the Ettus E310 hardware setup and working with Matlab.
I've installed the comms toolbox and the 'Communications System Toolbox Support Package for USRP® Embedded Series Radio'. However, when I come to the hardware setup I run into problems. I have got the SD card written, and when I get to the 'Verify Radio Connection' it can do the first two two tests (pinging the device), however, when it tries to 'Read hardware information from the radio hardware' it has an error message of 'Incompatible hardware'. On the Matlab terminal this error message is printed out:
%
## Establishing connection to hardware. This process can take several seconds.
Warning: A standard exception occurred during the execution of a driver function. The exception reported was:
(in driver function 'createDriver') testmeas:plugin:pluginNotLoaded Failure to load the requested plugin:
C:\ProgramData\MATLAB\SupportPackages\R2017b\toolbox\shared\sdr\sdrplug\sdrpluginbase\host\derived\bin\win64\libmwsdrembed.dll.
> In comm.internal.SDRSystemBase/infoImpl
In comm.SDRDevUSRPEmbeddedSeries/info
In comm.SDRDevUSRPEmbeddedSeries/getInfo
In usrpembradio.internal.hwsetup.HardwareInterface/getInfo
In usrpembradio.internal.hwsetup.screen.ConfirmConfiguration/testConnnection
In usrpembradio.internal.hwsetup.screen.ConfirmConfiguration>@(varargin)obj.testConnnection(varargin{:})
In matlab.hwmgr.internal.hwsetup.executeWidgetCallback (line 15)
In matlab.hwmgr.internal.hwsetup.Widget/safeCallbackInvoke (line 114)
In matlab.hwmgr.internal.hwsetup.hg.Button/buttonPushedCbk (line 43)
In matlab.hwmgr.internal.hwsetup.hg.Button>@(varargin)obj.buttonPushedCbk(varargin{:}) (line 24)
## Establishing connection to hardware. This process can take several seconds.
I don't know how to get it working, any help is greatly appreciated. I'm running the latest 2017b. Kind regards Will
  2 Comments
Will Thompson
Will Thompson on 5 Dec 2017
Hi Neil. Thanks for your reply. Yes I have that file in the folder, but still not getting passed the verification.
But I've not dropped back to 2017a, and it all works. I guess there is a slight issue with the current 2017b. Thank you for your help but I will just stick with 2017a for now.
Kind regards Will

Sign in to comment.

Answers (1)

Neil MacEwen
Neil MacEwen on 23 Feb 2018
Hi Will,
Another customer has experienced the same issue, and by comparing their installation with yours, we were able to figure out that there is a dependency in our code on Simulink. If you are able to install Simulink, this should fix your problem.
We will look into seeing if we can remove the dependency.
Thanks,
Neil

Tags

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by