MATLAB Answers


NXT MINDSTORM Toolbox: The "fantom" library could not be loaded. Mac OS X 10.12

Asked by Rachanon W. on 19 Apr 2018
Latest activity Edited by Alessandro Peloni on 31 Aug 2018

I am having a problem using the RWTH Mindstorm NXT Toolbox. I tried running the example files and the same error keep popping up.

"The "fantom" library could not be loaded. Make sure the official Mindstorms NXT driver is installed correctly!"

I am using MATLAB R2018a trial version on MacBook with Mac OS X 10.12. I've installed the RWTH Mindstorm Toolbox in MATLAB and the LEGO MINDSTORM DRIVER from the lego website. I've followed the instruction of the toolbox but didn't succeed or get anywhere. I've tried reinstalling the driver many times.

I am considering buying Matlab but with this problem, I am starting to be unsure about getting the license. I am very new to MatLab as a High School Student. If anyone have a solution please suggest them as I am running out of trial time, Thank you in advance.


I've tried disabling the SIP but the problem still persist. Could the problem cause from different source(s)?
I've looked more into SIP and Kernel Extension(Kent). I've found this information. I don't know if this is useful or not but it seem a bit relevant. This is from the System Information > Software > Extension.
Sorry, I am not familiar with iokit .

Sign in to comment.

1 Answer

Answer by Alessandro Peloni on 31 Aug 2018
Edited by Alessandro Peloni on 31 Aug 2018
 Accepted Answer

Hi Rachanon,
Connection to LEGO MINDSTORMS NXT can be achieved from MATLAB by using the third-party toolbox RWTH - Mindstorms NXT Toolbox. However, this is a third-party toolbox and we at MathWorks do not have access to the source code. As such, unfortunately, we cannot give you assistance on this issue. Posting your question on this forum is definitely a good idea to have answers, feedback, and comments from other MATLAB users, as Walter's prompt reply demonstrated. In the case you cannot find the answer that you are looking for in this forum, I suggest you ask directly to the developers of the toolbox. You can find them on the website linked below:
Please note that the latest stable version of the toolbox dates February 2012. As such, the issue that you are facing might be due to the newer version of the Operating System and/or the newer version of MATLAB, for which the toolbox has not being tested by the developers in RWTH Aachen.
If instead you want to use the Simulink Support Package for LEGO Mindstorms NXT Hardware, please be aware that such support package is supported on MATLAB up to the R2016b release. You can find a list of the Hardware Support Package System Requirements on the following link:
We recommend migrating to LEGO MINDSTORMS EV3 hardware and use LEGO MINDSTORMS EV3 Support from MATLAB instead, which is available for download for all platforms since MATLAB R2014b:
You might find the following MATLAB Answers post helpful:
If you are interested in purchasing a MATLAB license, you can get in touch with one of our sales representatives by following the link below:
I hope this information helps you.
Kind regards,


Sign in to comment.