Effacer les filtres
Effacer les filtres

[ERROR] FOUserAgent - Image not found. Encountered using publish r2018a

9 vues (au cours des 30 derniers jours)
David Clemens-Sewall
David Clemens-Sewall le 26 Avr 2018
I recently changed from r2016b to r2018a and now the publish function is not displaying plots. When I attempt to publish the following code to pdf I receive the subsequent error and the pdf publishes without the plot.
Code:
% test_publish.m
figure;
plot(1:10);
<<untitled.tif>>
Error
[ERROR] FOUserAgent - Image not found. URI: C:/Users/David Clemens-Sewall/AppData/Local/Temp/test_publish_01.bmp. (See position -1:-1)
[ERROR] FOUserAgent - Image not found. URI: C:/Users/David Clemens-Sewall/AppData/Local/Temp/test_publish_01.bmp. (No context info available)
I'm operating on Windows 10 and unfortunately I had already deleted r2016b so I cannot simply return to using that. By saving the plot and then loading it explicitly I can add it to the pdf. So it seems that publish is capable of loading and displaying the image it's just that matlab is trying to write the plots to a location it cannot access (the directory does exist, but when I go there I do not find the plots). I've looked at changing my temporary directory but unfortunately clear all followed by setenv doesn't seem to change that either (it keeps stubbornly returning to 'C:/Users/David Clemens-Sewall/AppData/Local/Temp/'). So I'm not sure where to go next. Thank you!
  8 commentaires
Image Analyst
Image Analyst le 6 Juin 2018
Did you change your original question and code? This code
% test_publish.m
figure;
plot(1:10);
<<untitled.tif>>
that you posted would not cause any problem. It will run (I tried it), though if you call it publish.m, it will override the build-in publish() function, which is never a good idea.
VIVEK RUHELA
VIVEK RUHELA le 27 Fév 2019
I am facing the same problem in Matlab-2018b. With code given in question, I am not getting any image in pdf file. Rest plot is working fine but while publishing, I am getting the same error as reported in the question. Any other suggestions....
Thanks

Connectez-vous pour commenter.

Réponses (7)

Ben Drebing
Ben Drebing le 5 Juin 2018
It looks like this error happens if there is a space in a folder name in the path to your current working folder. So, if you move your code somewhere else so that none of the folders in the path have a space in their name, you should be able to publish.
  5 commentaires
Walter Roberson
Walter Roberson le 5 Mai 2020
Brad Stiritz, I do not think you are encountering the same problem.
ava yektaeian
ava yektaeian le 29 Nov 2021
Thanks, really helpful

Connectez-vous pour commenter.


Marc Youcef
Marc Youcef le 5 Mai 2020
I am still having this issue on R2020a which is a long way from when that problem was first spot...

Cesar Martinez Delgado
Cesar Martinez Delgado le 21 Août 2018
Modifié(e) : Cesar Martinez Delgado le 21 Août 2018
I have the same problem when I try to publish pdfs or docs. I have tried to change the entire folder to a new one that does not have space in the name. Also, I tried adding to the path the folder that is show in the error. And kind of made the entire track of the function publish to catch the mistake because it. But, it always drops the same error heading to the same path, using the OP sample: C:/Users/ David Clemens-Sewall/AppData/Local/Temp/ Any further assistance on this? Changing the user name would in theroy help, but i do not know if it is gonna mess other applications, which I would avoid to happen. thank you

Ryan Whitney
Ryan Whitney le 24 Sep 2019
I continue to run into this issue. Sometimes it happens and if I change something in the code (minor, unrelated) or restart Matlab and it will output.
Other times, like RIGHT NOW (very frustrated) there appears to be nothing I can do to export this to PDF. I've had this issue on multiple versions :(.
I'd like to see MathWorks work on fixing this as they are clearly putting work into Livescripts and having the ability to run an analysis and export to PDF is super useful (still some formatting controls to work out, but I'm patient on that).
I'm running 2019b, on MacOS 10.14.6.
  1 commentaire
Ryan Whitney
Ryan Whitney le 24 Sep 2019
I've looked in the folder on my laptop where the images are supposed to be and it does not exist. So that explains the error - but I see all the plots in the viewer, but they are not where Matlab wants to look on the file system.

Connectez-vous pour commenter.


Robert Herring
Robert Herring le 1 Fév 2020
The easiest way to solve this is by changing your user environment variables so that the TMP and TEMP variable have a filepath with no spaces in them. I made a folder on my C drive called 'Temp', then set the environment variables TEMP and TMP for my user to 'C:\Temp'. The following Micrsoft tutorial will help.

Antonio Javier Barragán Piña
Adding as first line of code this works for me (it is a comple clean of MATLAB environment):
clc, clear all, close all
  4 commentaires
Jeroen Vermond
Jeroen Vermond le 18 Oct 2020
For me as well, thanks!

Connectez-vous pour commenter.


Sanqiang Zhong
Sanqiang Zhong le 23 Mar 2021
I run into the same problem. I solve it by saving the .xml file first before converting it to PDF.

Catégories

En savoir plus sur Startup and Shutdown dans Help Center et File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by