Effacer les filtres
Effacer les filtres

Processor-in-the-loop Arduino simulation with double data type

14 vues (au cours des 30 derniers jours)
Kaloyan Yordanov
Kaloyan Yordanov le 22 Juin 2018
I want to perform processor in the loop simulations of a subsystem (controller) in my model on an Arduino Uno board. I successfully generate a PIL block, however I run into the following error message when I start the simulation:
Data type "double" is not supported for SIL or PIL execution with the current target configuration. This is because the host size (8 bytes) and target size (4 bytes) do not match. To avoid this error, do not use this data type at the component interface.
I've tried using the single precision conversion tool with no effect and also tried surrounding the subsystem with the respective conversion blocks.

Réponses (2)

Gayatri Menon
Gayatri Menon le 26 Juin 2018
Hi,
Could you try adding data conversion block inside the subsystem and delete the folders that contain the generated code before trying again.
Thanks
Gayatri
  4 commentaires
Yuan Qi
Yuan Qi le 27 Juin 2018
I solved it by changing the default parameter behavior to Inlined and the parameter structure to NonHierarchical.
CHELLAKHI ABDELKHALEK
CHELLAKHI ABDELKHALEK le 30 Déc 2023
where you are doing this?
can you provide more information please.

Connectez-vous pour commenter.


Piyush Kadkol
Piyush Kadkol le 13 Oct 2018
Hi Yuan, I tried changing the Default Parameter Behaviour to Inlined and Parameter Structure to NonHierarchical, but am still getting the error. Could you suggest anymore changes that are needed to be done to overcome this problem? Thanks!
  1 commentaire
Jose GL
Jose GL le 30 Mar 2019
Hi!
I've the same problem with TI MCU.
The block that you will converter in PIL block has double data type, you need to changue all data type from double to single.
Regards

Connectez-vous pour commenter.

Catégories

En savoir plus sur Arduino Hardware dans Help Center et File Exchange

Produits


Version

R2018a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by