How can i resolve the ESP8266 compilation error caused by the Arduino Support Package?

46 vues (au cours des 30 derniers jours)
I am unable to build any of my ESP8266 boards after i installed the Arduino Support Package on my machine.
Error Debug message:
In file included from c:\programdata\matlab\supportpackages\r2018a\3p.instrset\arduinoide.instrset\idepkgs\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2\xtensa-lx106-elf\include\c++\4.8.2\algorithm:60:0,
from C:\ProgramData\MATLAB\SupportPackages\R2018a\3P.instrset\arduinoide.instrset\idepkgs\packages\esp8266\hardware\esp8266\2.4.2\cores\esp8266/Arduino.h:255,
from sketch\ESP8266.ino.cpp:1:
c:\programdata\matlab\supportpackages\r2018a\3p.instrset\arduinoide.instrset\idepkgs\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2\xtensa-lx106-elf\include\c++\4.8.2\utility:68:28: fatal error: bits/c++config.h: No such file or directory
#include <bits/c++config.h>
compilation terminated.
exit status 1
Error compiling for board NodeMCU 1.0 (ESP-12E Module).
  5 commentaires
Siddharth Vaghela
Siddharth Vaghela le 8 Fév 2019
Hi Arpita,
Haben's solution fixes the external Arduino IDE build issues but it breaks the MATLAB hardware support package! When I try to run arduinosetup, it throws an "samd unknown architecture" error.
Siddharth
HabenG
HabenG le 9 Fév 2019
Thats true, when you need to use the MATLAB hardware package just go back to the file and change it back.

Connectez-vous pour commenter.

Réponse acceptée

HabenG
HabenG le 16 Déc 2018
It turns out that when you use the arduino suport package in matlab things get screw up a bit thats for mathworks to figure out but as for this issue you have to go to C:\Users\Your user name here \AppData\Local\Arduino15 and find the preference text file, in the file chage the settings.path to where you have your arduino...typically C:\Users\Your user name here \Docments\Arduino and that should fix it.
  6 commentaires
William Arevalo
William Arevalo le 8 Juil 2021
Thank you very much, I wasted a lot of time trying to solve this problem, but this solution work so good, really thanks

Connectez-vous pour commenter.

Plus de réponses (3)

Zaid Haymoor
Zaid Haymoor le 22 Oct 2018
I had this problem, and I have just solved it by going to C:\Users\Zaid\AppData\Local
then search for the folder arduino or arduino15
Uninstall the IDE then remove this folder, matlab changes the configuration of the IDE somewhere in this folder so it starts reading the boards from somewhere else,, after deleting the folder Arduino or arduino15 or both you can reinstall the arduino IDE and reconfigure the esp boards from boards manager after adding the jason extension from preferences as before and it will work
  7 commentaires
Lau Boon Chong
Lau Boon Chong le 24 Mai 2021
Thank you @Zaid Haymoor, your answer solved my problem. Thank you very much

Connectez-vous pour commenter.


Walter Roberson
Walter Roberson le 29 Sep 2018
  3 commentaires
KT Naveen
KT Naveen le 17 Oct 2018
can u give anyother suggestion?...still facing the same issue..

Connectez-vous pour commenter.


Mursina Begum
Mursina Begum le 30 Oct 2019
Hi, I am new to nodemcu. When I was using ESP8266WiFi.h, I got the error "Error compiling for board NodeMCU 1.0 (ESP-12E Module)" which said that Multiple libraries were found for ESP8266WiFi.h. I solved by simply put the void loop(){} empty function at the end of my code. Now It's working...

Catégories

En savoir plus sur Arduino Hardware dans Help Center et File Exchange

Produits


Version

R2018a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by