Cannot find an ADALM-PLUTO radio.

9 views (last 30 days)
Manfred Lichtenwagner
Manfred Lichtenwagner on 9 Dec 2018
Answered: Alexandra Lopes on 2 Jan 2022
Hi,
at the end of the installation of the Support Package "Communications Toolbox Support Package for Analog Devices ADALM-Pluto Radio" I get an "Hardware Setup Error" that the Adalm-Pluto cannot be found. A view to WIndows System shows the Adalm Pluto.
I tried to unistall an install several times, but it dindn't help.
MATLAB Version: 9.3.0.713579 (R2017b)
Operating System: Microsoft Windows 10 Home Version 10.0 (Build 17134)
adalm_pluto_1.JPG
adalm_pluto_2.JPG

Answers (5)

Noam Levine
Noam Levine on 14 Jan 2019
I'm assuming you have Commnications Toolbox installed...
If so, here are a couple of things to try:
  • Make sure that no other software applicaiton is talking to the Pluto (if you were using IIO Oscilloscope, make sure it's closed before launching MATLAB)
  • On some computers, the single USB cable connection for power and signal is not sufficient for powering the Pluto, so you get strange results. You can try running a second USB cable to the Pluto power input to see if that "wakes up" the device.

Borja Marcos
Borja Marcos on 5 Sep 2019
I had a similar problem on Mac OS X and the culprit was the "HoRNDIS" driver, an Ethernet driver so that the unit is accessible via IP.
Try deinstalling the Ethernet NDIS driver for it.

Jay Weitzen
Jay Weitzen on 17 Jan 2020
I am having this problem with windows 10 and R2019b. Pluto with 2 separate usb.

thomas junker
thomas junker on 5 May 2021
I have the same problem with a full mathlab (release R2021a Update 1) crash reporter message.
funny no-one sees a final solution here

Alexandra Lopes
Alexandra Lopes on 2 Jan 2022
Looking for an answer yet...

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by