MATLAB Answers

SDR using AD9361 multi-FMCOMMS I get the following error.

6 views (last 30 days)
jarul
jarul on 15 Apr 2019
Commented: jarul on 30 May 2019
I ran the following MATLAB code and get the following error code:
Transmit and Receive LTE MIMO using Analog Devices AD9361/AD9364.
It is not decoding correctly. I get the following errors:
The error file is attached along the error.txt file.
Can someone help me what is going on? It is to do with the MATLAB.
Thanks
JAR
  3 Comments
Ross Elliot
Ross Elliot on 16 Apr 2019
Just to confirm that you are running this example (Transmit and Receive LTE MIMO Using a Analog Devices AD9361/AD9364) on two separate Zynq boards, each with a different IP address?
In order to do that you would need to modify the example code. Can you please attach your code, and I can take a look?
Can you also confirm that running the example on a single Zynq board, unmodified, works as expected?
Thanks,
Ross.

Sign in to comment.

Accepted Answer

jarul
jarul on 17 Apr 2019
Thanks for your response. Yes, the Code (Transmit and Receive LTE MIMO) works fine for a single SDR fine. However, when I run on two separate IP addresses, it does not run correctly. I have Ubuntu 18.04 installed and matlab installed on this machine.
I also tried to run this code from the following github link which claim to run for two separate IP addresses. This also gives me the same error.
The code Main_TwoBoard.m is meant for two separate IP addresses. Even this code gives the same error.
I am attaching my code in a zipped file. YOu need to change the IP address for your use.
Thanks for your help.

More Answers (1)

Ross Elliot
Ross Elliot on 17 Apr 2019
The reason that your version is failing is because you have modified the code in the ltePDSCHDecode function on line 182 where lteDeprecode is called. The second input to the function should be a structure, but you are passing a char. The error message that you are seeing explains this:
Error using mwltelibrary The MEX Library function call (lteDLDeprecode) resulted in an error: Parameter is not a structure (error getting structure field NLayers)
You have also modified the receive algorithm on line 362 of antead9361.m so that you are no longer assigning the detected number of cell reference ports to the eNodeB structure. This will also cause the receiver to fail to decode.
I modified your version of ltePDSCHDecode to be the same as the shipping LTE Toolbox function, and reverted your change in antead9361.m to assign the detected value of 'CellRefP' to the eNodeB structure, 'enb', and was able to run decode successfully.
Thanks,
Ross
  3 Comments
jarul
jarul on 30 May 2019
Hai Neil,
Thanks for your quick response. I do understand.
JAR

Sign in to comment.

Categories

Tags

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by