what(): Unable to launch the MATLABWindow application during installation

775 views (last 30 days)
So, I'm running a fresh install of Manjaro Gnome and I'm trying to install matlab. I downloaded the installer, unpacked but when I try to run "bash ./install" it gives me the error:
terminate called after throwing an instance of 'std::runtime_error'
what(): Unable to launch the MATLABWindow application
Matlab version is R2020a.
David Foster
David Foster on 11 May 2021
Thank you Daniel Morberg! Solved for Matlab R2021a on Redhat Enterprise Linux 7 (RHEL7.9)

Sign in to comment.

Accepted Answer

shichao ni
shichao ni on 31 Mar 2020
You are missing 'libselinux.so.1"
yay -S libselinux
and retry

Sign in to comment.

More Answers (2)

Brian Zelenke
Brian Zelenke on 23 May 2020
The MATLAB 2020a installer contains its own shared library libcrypto.so.1.1, but uses the system library libk5crypto.so.3. System library libk5crypto.so.3 uses new symbols, which system library libcrypto.so.1.1 has, but MATLAB's library libcrypto.so.1.1 doesn't. So, you have to delete the MATLAB installer's copy of libcrypto.so.1.1. The sequence of commands that worked for me in RHEL 8.2 were:
cd /home/YourUserName/Downloads/matlab_R2020a_glnxa64/bin/glnxa64
rm libcrypto.so.1.1
sudo su -
cd /home/YourUserName/Downloads/matlab_R2020a_glnxa64
export DISPLAY=':0'
That got the installer to work.
P.S. -- When I got to the step of entering my MathWorks account password in the resulting MATLABWindow application, the password field wouldn't let me type until I selected "Show Details" from the "MathWorks Product Installer" drop-down menu in the top menu bar and then clicked back into the main screen of the MATLABWindow application. Basically, I think I had to remove and restore focus on the MATLABWindow application main screen to get the password field working again.
P.P.S. -- Thanks to Petr at https://bugzilla.redhat.com/show_bug.cgi?id=1829790 for pointing me in the right direction on this.
Manuel Schneckenreither
Manuel Schneckenreither on 4 Apr 2022
see here: https://www.reddit.com/r/archlinux/comments/tkas9q/comment/i2h3r5t/?utm_source=share&utm_medium=web2x&context=3

Sign in to comment.

逸飞 吴
逸飞 吴 on 11 Nov 2020
The above answers don't work for me.
My solution is to run
from my home directory (or it will complain and exit), and things get to work well.
If you want to install MATLAB to somewhere outside your home directory, don't forget to add sudo.

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by