Probelm with web app server

51 views (last 30 days)
Martin Andersson
Martin Andersson on 26 Feb 2021
Answered: Daniele on 5 Jul 2022
Hi,
I instaled matlab web app server (2020a) six mouth ago and evrything was fine. But las week I could not get it to start, so I reinstalled the web app server.
But once pressing start I get the error "[SC] StartService FAILD 1068: the dependency service or group failed to start"
Could someone please help me with this problem.

Answers (3)

J. Alex Lee
J. Alex Lee on 21 Apr 2021
Edited: J. Alex Lee on 21 Apr 2021
@Martin Andersson, hope you have resolved this by now as it has been over a month, but if not, check your windows service account's password/disabled status.
I ran into this issue last week, and despite @Anshika Chaurasia's answer about relating to the port, the root cause ended up being a logon failure of the local windows service account associated with running the web app server (local/MwWebAppServerR20XXy, or whatever is the default) due to an expired password.
  8 Comments
D D
D D on 19 Feb 2022
Thanks! You saved my day.

Sign in to comment.


Anshika Chaurasia
Anshika Chaurasia on 3 Mar 2021
Hi Martin,
The "StartService FAILED 1068" error appears when the port that your server is trying to use is unavailable. This typically happens when the port is being blocked by another instance of Web App Server.
In order to check whether the port is already in use, you can follow these steps:
1) Open the "Resource Monitor" application in Windows.
2) Navigate to the "Network" tab within the Resource Monitor and expand the list of "Listening Ports".
3) If the port that your Web App Server is using is listed in "Listening Ports", then the port is already in use and Web App Server will not be able to access the port. By default, Web App Server will attempt to access port 9988.
If you find that the port is already in use, you have two options:
1) Stop the service that is opening the port by opening the "Services" application in Windows, finding any instances of Web App Server, and right-clicking on these services and selecting "Stop".
2) Change the port that your Web App Server instance is using. You can doing this using the "Port Number" option on the "Configure and Run" tab of the Development Web Apps Server application.
If you continue to experience issues after following these steps, then your firewall may be blocking the port. If this is the case, then you would need to allow the port in your firewall's settings.
Hope it helps!

Daniele
Daniele on 5 Jul 2022
Hi Martin,
I just unregistered and re-registered the web app services (using the default account) and the error disappeared.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by