MATLAB Answers

Problem with Signal Processing Toolbox after installing Wavelet Toolbox

9 views (last 30 days)
Vicente Garção
Vicente Garção on 19 May 2021
Edited: Vicente Garção on 24 Jun 2021
Hello,
Since I installed the Wavelet Toolbox for Matlab 2019b, I have been having problems with the Signal Processing Toolbox.
The functions fvtool and spectrogram dont work, as they dont detect some subfunctions. Fvtool has the error "undefined function 'engunits'" and spectrogram has the error "Unrecognized function or variable 'psdfreqvec'." This psdfreqvec function was probably supposed to be in the signal toolbox's private functions but it isnt there for some reason.
Unrecognized function or variable 'psdfreqvec'.
Error in computeDFT>computeDFTviaFFT (line 91)
f = psdfreqvec('npts',nfft,'Fs',Fs);
Error in computeDFT (line 45)
[Xx,f] = computeDFTviaFFT(xin,nx,nfft,Fs);
Error in pspectrogram (line 67)
[y,f] = computeDFT(bsxfun(@times,win,xin),nfft,Fs);
Error in spectrogram (line 183)
pspectrogram({x},'spect',varargin{:});
I've tried uninstalling and reinstalling these toolboxes, updating the toolbox cache with the rehash function, updating matlab 2019b to version 8 and restoring the default path, with no success.
Thanks in advance for your help!
EDIT: I fixed the problem by doing a fresh reinstall of MATLAB!

Answers (1)

Kiran Felix Robert
Kiran Felix Robert on 23 Jun 2021
Hi Vincente,
MATLAB uses hierarchy (priority) to call functions of same name present in multiple toolboxes.
Since you are getting an error for 'engunits' and 'psdfreqvec' function, try the following command
which -all engunits
% and
which -all psdfreqvec
The above code will give you the priority hierarchy, the one displayed in the top will be executed when the function is called.
Refer the search path documentation.
Refer the following answer for more details.
You can always use set path dialog box from the MATLAB toolstrip and Move down the function priority after rehashing the search path.
  1 Comment
Vicente Garção
Vicente Garção on 24 Jun 2021
Thanks! I had tried that, but the functions did not show up when I used the which -all command. I did fix the problem by completely reinstalling MATLAB though!

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by