MATLAB Answers

Carmaker for simulink mex file not unloaded from memory

6 views (last 30 days)
Omkar Karve
Omkar Karve on 24 Jul 2021
Edited: Omkar Karve on 24 Jul 2021
I am using Matlab 2020b and Carmaker 10. When I run(simulate) Carmaker for Simulink model (even the generic model) for the first time (after a full Matlab restart), it runs fine and I can stop the simulation. But when I run (by either pressing Simulate on Simulink or Start on Carmaker GUI) it again, I get this error. I have tried munlock, clc, clear. But nothing seems to work and I have to restart matlab entirely as suggested by the error. This error seems to suggest for some reason, the libcarmaker4sl.mexw64 was not unloaded from Matlab in the previous run. Any ideas why this might be happening? (I repeated the same experiment with 2019a and CM 9.1 with same results).

Answers (0)




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by