MATLAB Answers

I can no longer perform coverage analysis, what could be the problem?

2 views (last 30 days)
Hello Matlab Gurus,
I am running a bunch of tests using Simulink Test tool. I have the Enable coverage analysis switched on for the models configuration. I have it enabled for the Test file, but no coverage analysis is carried out. Is there some setting somwhere else that is stopping the analysis? Will it work in Accelerated mode? If it won't work in anything except Normal mode surely a warning or an error message would be nice?
Cheers
Richard

Accepted Answer

Jesús Zambrano
Jesús Zambrano on 12 Aug 2021
Edited: Jesús Zambrano on 12 Aug 2021
Apart from selecting "Enable coverage analysis", it is needed to specify one out of: Entire System, Referenced Models, Subsystems. From documentation see that:
Entire System (default): Coverage data is collected for the top-level model, as well as all supported subsystems and model references.
Referenced Models: Coverage data is collected for one or more referenced models. To specify the referenced models, use the parameter Select Models. You can also specify the top-level model itself.
Subsystem: Coverage data is collected for a specific subsystem. To specify a subsystem, use the parameter Select Subsystem.
You then run the model, and then should see a Coverage tab as part of the toolstrip, where you can get access to a report of the coverage details, generate a report, highlight coverage on the model.
Please have a look at the following example in the documentation:https://se.mathworks.com/help/slcoverage/ug/cumulative-coverage-analysis.html
Hope it helps!
  6 Comments
Jesús Zambrano
Jesús Zambrano on 12 Aug 2021
Absolutely! I think you made a good point. We really appreciate it. Thanks again!

Sign in to comment.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by