Library not loaded: @rpath/lib​cudart.10.​2.dylib

18 vues (au cours des 30 derniers jours)
Nitin Tandon
Nitin Tandon le 6 Juin 2022
Commenté : Fatemeh Taheri le 12 Juil 2022
I've recently been getting the following error when trying to run "bwlabel.m". Trying to run code that had been working as recently as a month ago. Any advice would be appreciated.
Running Matlab 2020b on Mac OS 10.15.7.
Unable to load bundle binary
/Applications/ Error:
dlopen(/Applications/, 10):
Library not loaded: @rpath/libcudart.10.2.dylib
Referenced from: /Applications/
Reason: no suitable image found. Did find:
/Applications/ code signature invalid for
  11 commentaires
Graham Fraser
Graham Fraser le 8 Juin 2022
Modifié(e) : Graham Fraser le 8 Juin 2022
I was able to work around this problem on Mojave (10.14.4) by copying:
Delete and reinstall MATLAB, Reboot, and bwlabel should work again.
This workaround doesn't seem to work on Catalina and above because root cannot modify /usr/lib. Disabling SIP protection may get around this but so far I haven't been able to get my solution to work even with SIP disabled.
Hope this helps get us closer to a permanent solution.
雨鑫 史
雨鑫 史 le 5 Juil 2022
I have the same problemi

Connectez-vous pour commenter.

Réponse acceptée

MathWorks Support Team
MathWorks Support Team le 22 Juin 2022
This error is documented here:
Please refer to the Bug Report for details concerning this issue and its resolution. You may also "Follow" the Bug Report to be notified of future updates regarding this issue.
  3 commentaires
MathWorks Support Team
MathWorks Support Team le 22 Juin 2022
The workarounds described below are not validated by MathWorks and may result in unintended consequences with our products. As such, these are not recommended. If you are not able to follow the instructions in the Bug Report, please contact MathWorks Technical Support and share your workflow.
Yuval Vardi
Yuval Vardi le 22 Juin 2022
The instructions in the Bug Report only ask to update to Matlab 2021a. What should we do if we cannot update the matlab version?

Connectez-vous pour commenter.

Plus de réponses (5)

guitalele le 13 Juin 2022
Modifié(e) : guitalele le 22 Juin 2022
For other mac users who don't want to update MATLAB and don't have access to /usr/lib: I found that copying the library to /usr/local/lib did the trick, provided I also added an 'ad-hoc' code signature, eg:
sudo cp /Applications/ /usr/local/lib
sudo codesign --deep -fs - /usr/local/lib/libcudart.10.2.dylib
Tested on:
  • R2020b on Big Sur (11.6.6)
  • R2019b on Mojave (10.14.6) - note libcudart version is different: libcudart.10.1.dylib
Note that this solution is just based on previous answers ( + ) + google + trial and error. I have no expertise in macOS code signing and would welcome thoughts from Mathworks or others on whether this is a sensible thing to do.
Update 22nd June: As pointed out by @Tyler Cumby in the discussion below, there is no need to move the file to /usr/local/lib - you can just run the codesign command directly on the relevant file
  14 commentaires
Jessica Zhao
Jessica Zhao le 28 Juin 2022
Works for me on macOS Monterey 12.4 for MATLAB R2020a too! Thank you!
Fatemeh Taheri
Fatemeh Taheri le 12 Juil 2022
It's work for me on macOS Big Sur 11.6. Thank you!

Connectez-vous pour commenter.

Bhavana Ravirala
Bhavana Ravirala le 9 Juin 2022
Hi Nitin,
Go through the following link which helps in eliminating the error.
Hope this helps.
  1 commentaire
Pierre Lanari
Pierre Lanari le 9 Juin 2022
Thanks for the suggestion.
As I don't have access to /usr/lib/ on Catalina, I have tried moving the library to my working directory (and various other locations in the MATLAB path).
I can find the library with the command:
which libcudart.10.2.dylib
However, this does not eliminate the error for me.

Connectez-vous pour commenter.

Naveh Levanon
Naveh Levanon le 9 Juin 2022
I had this problem now too in R2020b.
I installed R2021a fresh and the problem is gone. Others say re-installing R2021b works too. Possibly any re-install would fix this.
  4 commentaires
Pierre Lanari
Pierre Lanari le 10 Juin 2022
A fresh installation of R2021a did not solve the problem for me.
Joss Knight
Joss Knight le 13 Juin 2022
Hi Pierre. MATLAB does not ship the offending library (libcudart) in R2021a so I'd be interested for you to elaborate more to help us work out what's going wrong for you. Perhaps you are running a MEX function?

Connectez-vous pour commenter.

Abbas Ezzat
Abbas Ezzat le 11 Juin 2022
How can i run polymeric composite formulations to optimize selction criteria
  1 commentaire
Walter Roberson
Walter Roberson le 11 Juin 2022
I do not understand the relationship to the libcudart question?

Connectez-vous pour commenter.

Joss Knight
Joss Knight le 4 Juil 2022
This problem should now be fixed at Apple, please reboot and report here if you are still experiencing issues.


En savoir plus sur Startup and Shutdown dans Help Center et File Exchange




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by