Effacer les filtres
Effacer les filtres

Simulink: To Workspace block, collects only one or two data points (Running in External mode)

7 vues (au cours des 30 derniers jours)
I am running a simulink model in external mode, and I get only one data point after the run from "To workspace block". I have tinkered with the settings a lot to get this to work, but I am not able to get more than two data points.
I am using Matlab R2015b, model is running on Arduino Mega 2560. The following are the screenshots of the settings I am using: Model:
To Worksoace block setting:
Solver settings:
Data Import/Export:

Réponse acceptée

Boris
Boris le 12 Déc 2015
Unfortunately I have the same problem. It worked fine with R2014b and doesn't work with R2015a and R2015b.
If you (or someone else) finds a solution, I'm very interested.
  2 commentaires
Boris
Boris le 9 Mar 2016
How can my answer be the accepted one? I just said I have the same problem and still have the problem.
zaman  sowmik
zaman sowmik le 21 Fév 2020
because you are only one who has given an effort

Connectez-vous pour commenter.

Plus de réponses (5)

Min Seg
Min Seg le 1 Mar 2016
I have tried 2014b and that seems to work fine.

Vidya Viswanathan
Vidya Viswanathan le 1 Avr 2016
Hi,
I notice that in your model, the sample rate used is 6ms. Typically, the gap in output data is observed when the sample rate is less than 10ms because the target tries to upload the data to the host every few seconds.
To resolve the issue,
1) Please increase the duration further in your model and see if it satisfies your requirements. Ideally, it is not recommended to run external mode on Arduino targets at very high rates (such as 1 ms).
2) If your requirement is to have data archiving at very high speeds, it is recommended to use a serial block for data upload. You would then use an ICT receive block on the Host to log data into MATLAB.
I hope this addresses your query.
Regards,
Vidya Viswanathan
  1 commentaire
N Kando
N Kando le 26 Jan 2017
Modifié(e) : N Kando le 26 Jan 2017
I am encountering the same issues with the MinSeg.
The dynamic data goes to scope without issue, but only the final value goes to the workspace.
I have tried an (inherited) simulation step of 0.1 [s], and also set the decimation to 10. This did not have any effect; only the final value appears.
[r2015b]

Connectez-vous pour commenter.


Auralius Manurung
Auralius Manurung le 26 Fév 2016
I am having the same problem in R2015b. Any update on this issue will be very much appreciated.

Giorgio Concu
Giorgio Concu le 6 Déc 2017
I had the same problem and I fix it just upgrading to R2016b.

Number seven
Number seven le 10 Mar 2022
I was having a similar issue where no data was being output to the workspace. I fixed it by going to tab Code > External mode control panel > Data Archiving. Then here I enabled Data Archiving, selected a directory and typed my desired file name. Now I have my variable in the To Workspace block being written to workspace, although I also get a file in the same directory with the name I set in Data Archiving.

Catégories

En savoir plus sur Simulink Functions dans Help Center et File Exchange

Produits

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by